iPad on Bubba

How are you using your Bubba? Got ideas for a cool modification? Share!
Locked
Tim
Posts: 36
Joined: 16 Jun 2007, 03:18
Location: Australia

iPad on Bubba

Post by Tim » 02 Jun 2010, 01:41

Hi,

Just to say that I got my iPad to work with Bubba Mail. The syncronization and search is pretty reasonable.

My Bubba has a static IP address with port-forwarding set up through my static IP modem/router to Bubba.

The iPad settings are:-
Accounts: Bubba >
Fetch New Data: Push > Manually

IMAP Account Information
Name: My Name
Address: MyEmail @something.com
Description: Bubba Email

Incoming Mail Server
Host Name: xyz.xyz.xyz.xyz
User Name: MyBubbaLoginName
Password: **************

Outgoing Mail Server
SMTP: mail.MyISP.com

[Advanced]
Mailbox Behaviours
Drafts Mailbox: Drafts >
Sent Mailbox: Sent Messages >
Deleted Mailbox: Deleted Messages (Bubba) >
Deleted Messages
Remove: Never >
Incoming Settings
Use SSL: [ON]
Authentication: Password >
IMAP Path Prefix: /
Server Port: 993

I have been using the iPad for 5 days now and I am generally pleased with how it works. I can manage Bubba through the web interface and can display supported files (PDFs and HTML) through the Bubba Filemanager. So far the only way that I have found to store and retrieve other files is as e-mail attachments.

--Tim

RandomUsername
Posts: 904
Joined: 09 Oct 2009, 18:49

Re: iPad on Bubba

Post by RandomUsername » 03 Jun 2010, 07:31

There are a few iPhone/iPad apps that allow you to browse samba shares - NetPortal is the one I use on my iPhone.

Dropbox are launching a client for ARM and PPC processors soon, that would be an excellent addition to my B2 combined with their iPhone app.

Tim
Posts: 36
Joined: 16 Jun 2007, 03:18
Location: Australia

Re: iPad on Bubba

Post by Tim » 03 Jun 2010, 12:28

RandomUsername wrote:There are a few iPhone/iPad apps that allow you to browse samba shares - NetPortal is the one I use on my iPhone.

Dropbox are launching a client for ARM and PPC processors soon, that would be an excellent addition to my B2 combined with their iPhone app.
Thanks RandomUsername - I have just tried Netportal. I managed to get it to work with an OS X machine and a Windows Samba server, but could not log-in to Bubba - I get an "Unknown user or password" error.

I have tried both:-

Display Name: Bubba
with
Name / IP address: as blank
DNS Domain suffix: as blank

and;

Display Name: as blank
with
Name / IP address: 192.168.0.xyz
DNS Domain suffix as blank

Do I need some additional information like workgroup or //servername/account ? to get Bubba to work?

Thanks,

--Tim

Tim
Posts: 36
Joined: 16 Jun 2007, 03:18
Location: Australia

Re: iPad on Bubba

Post by Tim » 03 Jun 2010, 14:14

Sorry RandomUsername,

I have dug around a bit and found the problem myself. Stratospherix have the following support article:
Connecting to NAS drives running old firmware
We have had a number of customers report a problem where they are unable to connect to their NAS drive and every username/password is rejected. This has been tracked down to these NAS drives running a very old version of Samba (3.0.10). If you are intending to use FileBrowser to access a NAS drive, we would recommend that you test the connection with NetPortalLite, our free iPhone app. If NetPortalLite can connect, then FileBrowser will also be able to.
My '"production" Bubba (the original Version 0.52.2) has Samba 3.0.14a-Debian and does not work

My test/backup/development Bubba 0.99.4-1 (with Lenny) has Samba 3.0.24 and works very well.

Hi Excito (Tor),

We early customers really need the stable Bubba Lenny image to be made available soon - It is now 10 weeks or so since you gave us an ETA. A realistic time for release would be appreciated. I would put the intermediate Lenny image into production EXCEPT that it gives the wrong disk size/usage and I still can't get Mail to work....

--Tim

DanielM
Posts: 637
Joined: 28 Mar 2008, 06:37
Location: Sweden

Re: iPad on Bubba

Post by DanielM » 04 Jun 2010, 15:59

Tim wrote:EXCEPT that it gives the wrong disk size/usage and I still can't get Mail to work....
My Lenny based Bubba 1 gives the correct disk usage numbers. I remember having this problem when I first installed and fixing it. Unfortunately that was a while ago :roll:

Anyway, I did some searching. Check the file /usr/share/web-admin/index.php for calls to disk_free_space and disk_total_space. In my index.php they say disk_free_space("/home/") and disk_total_space("/home/"). This COULD be the thing I changed...

/Daniel

Tim
Posts: 36
Joined: 16 Jun 2007, 03:18
Location: Australia

Re: iPad on Bubba

Post by Tim » 05 Jun 2010, 03:11

DanielM wrote:
Anyway, I did some searching. Check the file /usr/share/web-admin/index.php for calls to disk_free_space and disk_total_space. In my index.php they say disk_free_space("/home/") and disk_total_space("/home/"). This COULD be the thing I changed...

/Daniel
Thanks Daniel,

That fixed it.

--Tim

Locked