Problem updating Firmware

Got problems with Bubba? Then this forum is for you.
Posts: 4
Joined: 02 Sep 2011, 07:55

Problem updating Firmware

Post by scudeast » 05 Sep 2011, 09:41

Sorry would post this on the original Bubba forum but it seems locked....

I just reinstalled bubba.img and then tried doing a firmware upgrade and get:

Updating available sources... done
Checking for updates... done
5 package(s) to update.

However it has been stuck on "Upgrading..." for a few hours...

I tried to connect via the web interface in a new window but just get a Error 101 "(net::ERR_CONNECTION_RESET): The connection was reset." message (from Chrome).

I can't ssh in as I have no users set up (sshd seems to be running though).

Any advice?

Posts: 637
Joined: 28 Mar 2008, 06:37
Location: Sweden

Re: Problem updating Firmware

Post by DanielM » 05 Sep 2011, 11:54

Well, something is strange here. I moved the topic to the correct forum since I thought the problem was only that the poster is a forum newbie without posting rights. But it seems this forum is really locked. Why is this? Does this mean nobody can respond to this now? If so, I'm sorry for moving it...


Posts: 1470
Joined: 31 Dec 2006, 07:12
Location: Sweden

Re: Problem updating Firmware

Post by johannes » 06 Sep 2011, 02:26

Correct, we locked the Bubba1 forum since almost all posts were spam or B2/B3 questions posted wrong. Pehaps this was too fast, I'll unlock.
/Johannes (Excito co-founder a long time ago, but now I'm just Johannes)

Posts: 4
Joined: 02 Sep 2011, 07:55

Re: Problem updating Firmware

Post by scudeast » 06 Sep 2011, 05:25

Many thanks Johannes...

Well I solved this.

I recycled the power (oops..) after a while.. although it was apparently updating and I should have left it (see below)

Once restarted I added a user via the web interface and ssh'd into the B1

I then did a apt-get update / upgrade / dist-upgrade and could see that it started to continue a previous install of many files... I must have interrupted the upgrade during the power recycle, and I let it continue and 20 minutes later everything was updated and OK.

I have found with the Lenny image I can run *anything* that I run elsewhere under LAMP, although it is very slow (especially doing some extensive XML parsing in php...)

Good news:
Full 5.0.8 Lenny (quite a new build really)
Runs all my LAMP stuff
Great as a 24/7 device (I aim to make it a python web scraping device always running...)
Little Noise (only disk access)
500GB currently plenty

Bad News:
Can be slow as a LAMP Server - but that's down to running a 2006 first generation device :)

Would have liked:
External Disk ('Activity') light would have been nice (although can see the red one through the grill!)