GUI of an application from B3 on Linux machine through ssh

Got problems with your B2 or B3? Share and get helped!
Post Reply
amishorn
Posts: 21
Joined: 29 Feb 2012, 12:32
Location: Switzerland

GUI of an application from B3 on Linux machine through ssh

Post by amishorn » 15 Aug 2013, 06:20

Hi at all

I've found a HowTo for running a user interface on a Windows machine. (Running graphical application from Bubba on your windows pc) From that I derrived the principle for a Linux machine, however it doesn't work. My goal is to run a mysql frontend like Emma in order to configure the mysql server in a more convenient way.

Till now I additionally installed the following packages on my B3:
  • - xbase-clients
    - x11-common
    - xterm


with the command:
  • apt-get install xbase-clients x11-common xterm
as mentioned in the tutorial. Furthermore, I installed as well emma on the B3. But now, I always get a list of warnings, headed by that one:

  • Invalid MIT-MAGIC-COOKIE-1 key/usr/lib/pymodules/python2.6/gtk-2.0/gtk/__init__.py:57: GtkWarning: could not open display warnings.warn(str(e), _gtk.Warning)

when I try to start Emma. Can anybody help me to get the user interface on my Linux machine? B.t.w., on my computer is aptosid running. It is a distribution based on debian.

Thank you very much in advance.
Regards, aimless

Ubi
Posts: 1547
Joined: 17 Jul 2007, 09:01

Re: GUI of an application from B3 on Linux machine through s

Post by Ubi » 15 Aug 2013, 06:31

Just a stab at the obvious before we go into the details:
* you are running your ssh client with ForwardAgent yes and ForwardX11 yes
* you already tried all the suggestions posted here: https://www.google.nl/search?q=Invalid+MIT-MAGIC-COOKIE

amishorn
Posts: 21
Joined: 29 Feb 2012, 12:32
Location: Switzerland

Re: GUI of an application from B3 on Linux machine through s

Post by amishorn » 15 Aug 2013, 09:48

Hi Ubi

Jep, yesterday night I tried a lot to get it working, however nothing led me to the goal. First I followed to this guideline: http://wiki.excito.org/wiki/index.php/R ... windows_pc what ended up with the message I've mentioned in my last post. Afterwards I googled and found several solutions and followed mainly to that one: http://www.gossamer-threads.com/lists/g ... ser/187879

However, then as I add the entry "ForwardAgent yes" to the sshd_config file of my B3 and rebooted it, I was no more able to connect to my B3 through ssh. Therefore, I took the HDD out of the housing and connected it to my desktop and had to notice that the sshd_config file of my B3 was empty. I copied the one of my desktop (Linux: aptosid) to my B3 and it worked again. As I now added the entry again and tired to reload the ssh, I got the following error message:

Code: Select all

/etc/ssh/sshd_config: line 63: Bad configuration option: ForwardAgent
/etc/ssh/sshd_config: terminating, 1 bad configuration options
Do I have to configure the sshd_config file of my desktop system as well?

Regards, aimless.

Gordon
Posts: 1373
Joined: 10 Aug 2011, 03:18

Re: GUI of an application from B3 on Linux machine through s

Post by Gordon » 15 Aug 2013, 13:42

If you're on windows I suggest you read this howto for putty. I've used putty before to do what you're trying to accomplish and it worked right out of the box.

Also, try something simple like xclock first.
Last edited by Gordon on 15 Aug 2013, 17:45, edited 1 time in total.

ryz
Posts: 183
Joined: 12 Feb 2009, 06:03

Re: GUI of an application from B3 on Linux machine through s

Post by ryz » 15 Aug 2013, 15:18

Nice to see that some one actually uses the wiki I wrote. Sorry it does not work for you.

First try to start an xterm. That is run the command

Code: Select all

xterm
You are running the command with the same user as you login in with ssh and not as root are you? You have to do some extra step to be able to start graphical application after you done a su to root .

You have to make sure that the xauth binary is installed. Just run

Code: Select all

xauth
to test if it is not installed install it with

Code: Select all

'apt-get install xauth

ryz
Posts: 183
Joined: 12 Feb 2009, 06:03

Re: GUI of an application from B3 on Linux machine through s

Post by ryz » 15 Aug 2013, 15:26

By the way ForwardAgent is an client configuration and not an server configuration so it should not be in the B3 configuration file hence the error message.

amishorn
Posts: 21
Joined: 29 Feb 2012, 12:32
Location: Switzerland

Re: GUI of an application from B3 on Linux machine through s

Post by amishorn » 16 Aug 2013, 02:23

Hi all

So, I am working again on the issue. Now I inserted the expession "ForwardAgent yes" in the ssh_config file of the desktop computer as it was recognized as a "bad configuration option" if I put it in the sshd_config file.

Following entries are now within the corresponding files:

On desktop computer (client):
  • In ssh_config:
    • ForwardAgent yes
      ForwardX11 no
On the B3 (server):
  • In sshd_config:
    • X11Forwarding yes
@ryz:
When I try to start the xterm I get the message:

Code: Select all

Invalid MIT-MAGIC-COOKIE-1 keyxterm Xt error: Can't open display: localhost:10.0
Yes, I am running on the command with the same user as I login and not as root unless I have to modify the configuration files.
The xauth seems to be installed, as it get started when I call it.

Additional note:
Always when I try to reload the ssh I get the message:
  • Could not load host key: /etc/ssh/ssh_host_ecdsa_key
However, I guess that it has no impact on my issue.

Regards, amishorn

Post Reply