Shutdown problem

Got problems with your B2 or B3? Share and get helped!
Post Reply
Joric17
Posts: 13
Joined: 05 Nov 2010, 16:16

Shutdown problem

Post by Joric17 » 05 Nov 2010, 16:26

Hello,

I installed my b3 and have the following issue:

I want to be able to shut down my b3 via the shell by a shutdown -h command but then the system hangs.
The led stays purple and the disk keep spinning.
Shut down by the gui or the hardware button is no problem.
Any idea?

Thanks,
Joric

Cheeseboy
Posts: 789
Joined: 08 Apr 2007, 12:16

Re: Shutdown problem

Post by Cheeseboy » 05 Nov 2010, 17:02

+1
I've had the same issue with Bubba Server, Bubba|2 and B3.
I tried poweroff and halt...

Ubi
Posts: 1547
Joined: 17 Jul 2007, 09:01

Re: Shutdown problem

Post by Ubi » 05 Nov 2010, 17:10

yeah it seems to be only in the lenny version, my old sarge edition shut down just fine. Theres another thread about this here says that shutting down via the web interface does shut down correctly, but I wonder what the difference of that action is from issuing the shutdown -h comand.

Joric17
Posts: 13
Joined: 05 Nov 2010, 16:16

Re: Shutdown problem

Post by Joric17 » 05 Nov 2010, 18:58

Well, B3 runs Squeeze, but i also like to know which command the gui uses to shutdown the system properly.

ryz
Posts: 183
Joined: 12 Feb 2009, 06:03

Re: Shutdown problem

Post by ryz » 06 Nov 2010, 09:10

I dont know about the B3 but for bubba 2 you can not use the shutdown or poweroff command to cut of the power. This is not implemented in hardware. What the web-interface do to power-off Bubba is to write some magic number to some magic memory area and the do a reboot. When the system starts up again and sees this magic number it cuts the power. There is some old thread talking about this http://forum.excito.net/viewtopic.php?p=8039#p8039

Joric17
Posts: 13
Joined: 05 Nov 2010, 16:16

Re: Shutdown problem

Post by Joric17 » 06 Nov 2010, 21:12

Great! that does the trick!
Thanks Ryz

Post Reply