Bubbagen live-USB for B3 updated (version 1.13)

Discuss development on Bubba
Gordon
Posts: 1395
Joined: 10 Aug 2011, 03:18

Re: Bubbagen live-USB for B3 updated (version 1.13)

Post by Gordon » 03 Apr 2020, 02:38

beatgr wrote:
02 Apr 2020, 16:34
So I installed the Bootable live-USB of Bubba OS on my SanDisk Cruzer Fit 16GB USB.
It successfully loaded on B3 , but did not mount the 3 TB hard drive.
That is correct. The Live-USB does not touch your hard drive unless you specifically tell it to (or run install)
beatgr wrote: LED was Green !
Logged in via SSH, and Ran “genup” ...
ran across issue where it was looking for path on Gordon’s repository (could not find).
I will see if that session was captured to recover.
Any more info on that? Was that related to the `bindist` flag issue reported earlier or did you run into something else?
beatgr wrote: Loaded the image on /dev/sda (3 TB hard drive), THEN “reboot”. LED is Blue !
Excellent! Enjoy your `new` B3 ;)

beatgr
Posts: 39
Joined: 01 Feb 2009, 15:25

Re: Bubbagen live-USB for B3 updated (version 1.13)

Post by beatgr » 03 Apr 2020, 13:13

Gordon wrote:Any more info on that?
Was that related to the `bindist` flag issue reported earlier or did you run into something else?
YES, the install error message seems to be related to ‘bindist’.

genup USE="-bindist" appears to have resolved, with a couple of minor errors.

gb

jallee
Posts: 49
Joined: 12 Jun 2009, 13:15

Re: Bubbagen live-USB for B3 updated (version 1.13)

Post by jallee » 05 Apr 2020, 04:30

Hi Gordon.
Trying out the newest bubbagen openRC version. :)

Code: Select all

# USE="bindist" emerge --oneshot --nodeps app-admin/bubbagen


!!! Problem resolving dependencies for app-admin/bubbagen

!!! The ebuild selected to satisfy "app-admin/bubbagen" has unmet requirements.
- app-admin/bubbagen-9999.5::bubba USE="bindist -systemd"

  The following REQUIRED_USE flag constraints are unsatisfied:
    systemd

# 
Do i need to change to the systemd version instead or is it possible to get it working on openRC also?
Regards // Jallee

Gordon
Posts: 1395
Joined: 10 Aug 2011, 03:18

Re: Bubbagen live-USB for B3 updated (version 1.13)

Post by Gordon » 05 Apr 2020, 07:30

Entering `--nodeps` on the command line is pretty dangerous. In this case it causes portage to select the highest available version which due to the chosen versioning method happens to be the systemd version.

Also, the `bindist` USE flag is strictly for me to be able to distribute the software, which would otherwise get me in trouble with patent restrictions. Unless you intent to redistribute the software it is my advise that you do not re-enable `bindist`.

jallee
Posts: 49
Joined: 12 Jun 2009, 13:15

Re: Bubbagen live-USB for B3 updated (version 1.13)

Post by jallee » 05 Apr 2020, 11:03

Ok i see.
It was this in the README.md file who got me wonder. :D

"This does not only set the bindist flag but also includes several package specific masks and USE flags required to handle conflicts with the bindist flag. When you are done installing your additional software and/or updates you can use the same command but now with USE="-bindist" to remove the bindist flag and related config files from portage settings."

Gordon
Posts: 1395
Joined: 10 Aug 2011, 03:18

Re: Bubbagen live-USB for B3 updated (version 1.13)

Post by Gordon » 06 Apr 2020, 14:34

Hmmm.... I definitely need to re-author that bit. At least the command in the code block...

Post Reply