upgrade problem

Got problems with Bubba? Then this forum is for you.
Locked
powerpk
Posts: 2
Joined: 31 Jan 2008, 06:55

upgrade problem

Post by powerpk » 31 Jan 2008, 07:06

Dear all,

After a long wait 12 days, to get my bubba and managed to break after a few minutes.

I created an account and ssh into it. Then I uncommented out sources and did apt-get update, went fine. Then apt-get dist-upgrade crashed halfway. There was a problem with a package (dhclient.. something like that cant remember). Then it took out web interface (php part).

Anyone had similar problems?

It might be easier just to reinstall rather than fixing package dependencies.

Thanks
PK

Clive
Posts: 148
Joined: 07 Mar 2007, 07:15

Post by Clive » 31 Jan 2008, 08:10

I had a similar problem last time I tried to update from the Sarge sources and it was some missing dependency on some package relating to dhclient. However, my web interface and bubba packages were unaffected.

PS - I guess I have the record for the fastest Bubba breakage, when removing it from it's packaging it slipped out of my hands and smashed the LED on the front ! (Quickly inserted a new one though)

msx
Posts: 106
Joined: 13 Jan 2007, 06:03
Location: Venice
Contact:

Post by msx » 31 Jan 2008, 09:39

Clive wrote:PS - I guess I have the record for the fastest Bubba breakage, when removing it from it's packaging it slipped out of my hands and smashed the LED on the front ! (Quickly inserted a new one though)
Loool :) Too much excitement for the shipping :P

Eek
Posts: 372
Joined: 23 Dec 2007, 03:03
Location: the Netherlands

Post by Eek » 31 Jan 2008, 12:41

Hi,

this is a known issue when you add the debian sources.
see http://forum.excito.net/viewtopic.php?t=832

Note: apt-get dist-upgrade is only for upgrading to a different debian version.
If you want to upgrade your packages to the highest level of their current version, use apt-get upgrade

cheers
Eek

Locked