Problem with downloads

Got problems with Bubba? Then this forum is for you.
Locked
andersagren
Posts: 1
Joined: 09 Jan 2008, 15:21

Problem with downloads

Post by andersagren » 09 Jan 2008, 15:49

Hi all!
I have a problem with torrent downloads on my Bubba.
This problem occur whether I use the web-GUI to add a link, or if I copy the torrent file into my torrent folder. I'm using the latest firmware (0.51.2).

Ok, here's my problem:
If I add a new download via the web-GUI, the entire GUI freezes after a few seconds. With the earlier firmwares the download was put in the download-list and I could see that everything worked. But nowadays I can't even click on any links. When I try to view the filemanager my browser just sits there, waiting for a reply. I usually close the browser after this.
If I wait about 20 minutes and then open a new browser, I'm able to log on to Bubba. But if I press the "View downloads"-link, the whole procedure repeats itself...
If I restart Bubba, or just FTD, everything seems to work at first. My downloads are showing ("Checking existing...") but after a while it freezes again...

Any ideas of what may be wrong?
In another post I read something about checking the /var/log/daemon.log:

Code: Select all

...
Jan  7 06:26:22 bubba modprobe: FATAL: Could not load /lib/modules/2.6.16.16/modules.dep: No such file or directory
Jan  8 06:25:45 bubba modprobe: FATAL: Could not load /lib/modules/2.6.16.16/modules.dep: No such file or directory
Jan  8 06:25:46 bubba modprobe: FATAL: Could not load /lib/modules/2.6.16.16/modules.dep: No such file or directory
Jan  9 06:25:43 bubba modprobe: FATAL: Could not load /lib/modules/2.6.16.16/modules.dep: No such file or directory
Jan  9 06:25:43 bubba modprobe: FATAL: Could not load /lib/modules/2.6.16.16/modules.dep: No such file or directory
Could this have anything to do with my problems? What other file can I check?
I think my downloads are still in progress (or something) because the WAN-LED on my router is constantly blinking, and the free disk space on Bubba is slowly decreasing. But I never see the target files in my download folder...

Best regards,
Anders

Frippe
Posts: 2
Joined: 13 Jan 2008, 12:07

You're not alone

Post by Frippe » 13 Jan 2008, 12:18

I have the exact same problem. I think I've rebooted it at least twenty times so far but it just freezes again.
I can't even log out from the web-GUI without it freezing.
I had the downloads working fine for a short while after the upgrade so I think something must have happened.

/ Frippe

JohanJ
Posts: 32
Joined: 21 Sep 2007, 09:15

Post by JohanJ » 13 Jan 2008, 12:38

Same here too dont works to put torrentfiles in torrent folder it hangs all the time.

tor
Posts: 703
Joined: 06 Dec 2006, 12:24
Contact:

Post by tor » 13 Jan 2008, 14:06

Hi,

Obviously something is wrong here.

The errror message about modprobe should have nothing to do with this. Its there since we have no modules installed.

Did all this start when you added torrrent files in the torrent directory? And if so, what method did you use to put it there? Upload via web-ui, ftp samba or something else?

Could someone also try to clean out the info added by the download manager. If you cant reach bubba via the web-admin ui you might have to log into bubba via a shell.

If the web-ui is responsive. Log into it as admin. Click services. Uncheck Up and downloads and press update Log out admin from the web ui and log in as the user with the problem.

As the user with problem click Filemanager. Mark the torrents folder and choose delete from actions to delete the complete torrent directory. Then enter the downloads directory by choosing the downloads directory in the filemanager. In this directory either delete all contents or move it out of the downloads directory. It should be completely empty.

Now log out again and log in as admin again. Start the download manager again by selecting services. Check Up and downloads again and click Update.

Now finally log in as the user with problems again and try to start a download. Please note carefully the steps taken when doing it. If it works, the problems where most likely due to some corrupt data, possibly some incompabilities between the old and the new downloader.

If the problems persists. Please let us know.

Best Regards,

/Tor
Co-founder OpenProducts and Ex Excito Developer

JohanJ
Posts: 32
Joined: 21 Sep 2007, 09:15

Post by JohanJ » 13 Jan 2008, 16:03

Ok

Did all that you write and :

first of all i started a torrent in downloads directory (paste a link) and it started perfekt.

The ill tried to save one file to the directory from my firefox in the torrent directory but when ill tried that i got a "Filhämtningsfel" the file cant save to that directory but the web gui did not frezze like before.
The i tried to upload in the file manager an it works ok.
But i cant save the torrent file direct in windows from tex firefox.

David
Posts: 3
Joined: 19 Sep 2007, 14:32

Post by David » 02 Mar 2008, 19:27

Well, can't do much more than confirming the hang of the web-ui for ftd when trying to add a torrent.

But, adding them manually by putting them in the torrent directory works, and what is more interesting, the dllist.php works if loaded directly in the web browser, it's just the regular interface through downloads.php that is messed up somehow.

Kalle
Posts: 15
Joined: 02 Aug 2007, 15:54

Post by Kalle » 20 Mar 2008, 06:17

I have the same experience as JohanJ, that is I can't save the torrent in the torrents-directory directly from Firefox. Any other way works fine.

Locked