Page 1 of 2

NFS on Bubba

Posted: 17 Jun 2008, 05:49
by pelle
Is there any guide on how to install support for NFS on Bubba?

Thanks / Pelle

Ps. I would like to use NFS instead of SMB, to see if my videofiles will play better on my Popcorn Hour Mediaplayer. Currently, with SMB mapped network shares, videofiles that are demanding on the bitrate (VOB:s etc) is not playing flawlessly.

Posted: 17 Jun 2008, 08:29
by habrys
I used this howto with good results: ... nd_client/

Don't forget to uncomment Debian repositories in /etc/apt/sources.list file and update the list of packages first (apt-get update).

PS. I use an NFS share to play movies from Bubba on my Tvix 6500-A media player. Never experienced stuttering, even with big HD files (720p or 1080p, 4-9GB).

Posted: 18 Jun 2008, 04:17
by pelle
Many thanks Habrys.

Do I understand correctly?

1. uncomment Debian repositories in /etc/apt/sources.list file
2. $ apt-get update
3. $ apt-get install nfs-common portmap
4. $ apt-get install nfs-kernel-server
5 $ cat /etc/exports (? *)
6. $ /etc/init.d/nfs-kernel-server restart
7. $ /etc/init.d/nfs-common restart

(? *) The “sharesâ€

Posted: 18 Jun 2008, 18:46
by habrys
Yes, essentially correctly.

On bubba:

1. Become root:

Code: Select all

Provide root password when asked.

2. Modify /etc/apt/sources.list file in your editor of choice. It should look like that after modifying:

Code: Select all

deb sarge main
deb sarge/updates main
deb sarge non-free

#deb bubba main
3. Update the list of packages:

Code: Select all

apt-get update
4. Install packages needed for NFS server:

Code: Select all

apt-get install nfs-common portmap nfs-kernel-server
(That's just 3 and 4 from your list merged into one command.)

5. Edit /etc/exports on bubba to define your shares. Mine looks like that (yes, just one line for one and only share):

Code: Select all

Which means, that all clients from the 192.168.*.* IP pool can mount /tvixhd1 directory for read/write access. You can fine tune access privileges using Linux access rights for users, groups and all on directory and file level - as usually. You can also restrict IPs, which are allowed to mount shares. For example this would allow only one client ( to access the share:

Code: Select all

6. Restart the NFS server:

Code: Select all

/etc/init.d/nfs-kernel-server restart
/etc/init.d/nfs-common restart
Do it each time you change something in /etc/exports to make your changes "visible" for clients (your media player in this case).

7. Configure the share in menu of your media player. Typically you need IP of your bubba and name of the share for this. I had to provide a single directory name on the root level (/tvixhd1) for my medie player. Shares like /home/storage/video didn't work. Obviously a bug in the firmware of Tvix. I just created a symbolic link on the root level and exported it via /etc/exports to solve that:

Code: Select all

ln -s /tvixhd1 /home/storage/video
Maybe it won't be neccessary in case of Popcorn.
It's also useful to give your bubba a static IP in your router's settings, so that it's visible always under the same IP. Otherwise DHCP could give it various IPs after each restart and settings in your media player could become invalid.

That's all. I hope I din't forget anything.

After installing of packages (4) don't forget to get /etc/apt/sources.list to it's original state and run

Code: Select all

apt-get update
again. Otherwise firmware update via button in the bubba's web interface won't work anymore.

Have fun!

Posted: 19 Jun 2008, 17:25
by Cheeseboy
Hi Pelle,

Sorry for non-related post in this thread:

Are you happy with the PopcornHour otherwise?
What kind of disk did you install? (I read some horrorstories concerning WD disks)

Please let me know if it works better with nfs (I find it a lot quicker than smb).
I'm thinking of getting one, but it would be good to know it worked flawlessly with the trusty old bubba before I actually spend money on it...



Posted: 03 Aug 2008, 07:30
by pelle
Many thanks Habrys!
Followed your instructions and NFS is now up and running on Bubba.
Now my movies plays much much better than before, with SMB.

ps. Cheeseboy:
I am currently running my Popcorn on a homeplug network, i.e. not wired. With this setup the Popcorn can play movies from the Bubba without any stuttering - except when it comes to some of my more bandwidth demanding videofiles, i.e. ISO, VOBs and such.

I am pretty sure that the stuttering in theese cases comes from the homeplug network and has nothing to do with Bubba itself. It is the same thing if I use my laptop wireless or wired.

I also use a wired networked PS3 to play movies from Bubba (using UPnP) and have never experienced stuttering with this setup.

I should say that I have no great experience in playing HD files 180/720 so I cant tell you what to expect in those cases. I have tried some HD-WMV movies and they play pretty well..

So: If you want to play AVIs, VOBs and such and have a wired network you should be more than fine with the Popcorn slash Bubba. I recommend using NFS though.

Posted: 16 Oct 2008, 04:45
by niklinds
Hi habrys

Can you please explain to me in detail? how you gotten the Tvix to work with Bubba2? with SAMBA config.

I have tried server name as bubba, bubba.local, bubba/storage/video, storage, video etc. but nothing works, PING is ok from the Tvix 6500 mediaplayer.

Posted: 17 Oct 2008, 09:02
by habrys
niklinds wrote:Hi habrys

Can you please explain to me in detail? how you gotten the Tvix to work with Bubba2? with SAMBA config.

I have tried server name as bubba, bubba.local, bubba/storage/video, storage, video etc. but nothing works, PING is ok from the Tvix 6500 mediaplayer.
Hi niklinds,

I don't use bubba two, just bubba one, but I don't think it makes any difference when it comes to configuration of Tvix. Both are just a Debian servers, even if two is Etch and one is Sarge.

Basically, if I remember correctly, you have to configure 2 parameters in the Tvix to connect to a server:
1. IP - this is correct, since you said ping works,
2. Share name - it depends here if you use Samba or NFS. I assume it's Samba if you didn't install NFS support on your bubba yourself. For samba you should use the same share name / path, you use connecting to bubba from your Windows PC (in Windows explorer or Network neighbourhood). Something like \\storage or \\storage\video should work I think (try slashes or backslashes). I don't remember exactly.

Unfortunately I cannot try it out myself, since my Bubba and Tvix are in Germany and I'm in Poland right now, but I'm sure it worked over Samba once too.

Alternately you could try to install NFS using my howto. It's much faster, than Samba (important for HD movies!) and here I remember exactly how to configure Tvix to work with bubba (see paragraph 7 of my howto), so I can help you further even without direct access to my bubba to try things out.

Edit: I just noticed you said, you use Samba after all. Overlooked that, sorry...

Bubba access from Kubuntu via NFS

Posted: 27 Nov 2008, 09:59
by Cohan
I've followed the NFS-guide and I (think I) have the NFS-server running. I've also installed the nfs-client on my desktop Kubuntu and tries to mount some directories, but

Code: Select all

sudo mount -t nfs bubba:/home/the_user /home/the_user/Bubba
only results in

Code: Select all

mount.nfs: mount to NFS server 'rpcbind' failed: RPC Error: Program not registered
mount.nfs: internal error
Anone who knows how to fix this? I've tried to google and I found two suggestions, 1. add the IP-adress of the client to the /etc/hosts.allow file (doesn't work) 2. Make sure rpcbind is running (Not installed and doesn't seem to be availible via apt-get) As none of the nfs guides I've seen mentions rpcbind it shouldn't have to be installed. Or?

Edit: To clarify things: I'm running a Bubba|Two. Just noticed that this thread I hijacked was for the older Bubba, but that shouldn't matter should it?

Posted: 26 Jan 2009, 04:40
by RealElwood
apt-get install nfs-common will not work for me, has the name changed?

Code: Select all

bubba:~# apt-get install nfs-common portmap nfs-kernel-server
Reading Package Lists... Done
Building Dependency Tree... Done
Package nfs-common is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
W: Couldn't stat source package list sarge/main Packages (/var/lib/apt/lists/ - stat (2 No such file or directory)
W: Couldn't stat source package list sarge/updates/main Packages (/var/lib/apt/lists/security.debian.org_dists_sarge_updates_main_binary-arm_Packages) - stat (2 No such file or directory)
W: Couldn't stat source package list sarge/non-free Packages (/var/lib/apt/lists/ - stat (2 No such file or directory)
W: You may want to run apt-get update to correct these problems
E: Package nfs-common has no installation candidate

Posted: 26 Jan 2009, 08:49
by ian
I think you may need to change your sources.list: see this thread

Posted: 26 Jan 2009, 15:30
by RealElwood
Thanks ian, worked much better.

I followed the guide including the line

Code: Select all

ln -s /tvixhd1 /home/storage/video
What does this command mean?

I'm trying to mount the NFS share on my dreambox, which is a DVB-C cable box, running a linux os.

I can input IP of mount and local dir for the mount. ip is, but what should the local dir be?
should it be /home/storage/video/db or just /db?

Also when i did the command

Code: Select all

ln -s /tvixhd1 /home/storage/video
i can't see the folder in /home/../video/ neither in windows or web gui, however it's visible in my FTP browser under /video/.

Posted: 27 Jan 2009, 06:05
by ian
I think the command is to create a symlink (but I'm no Linux expert).

I think what I did was to edit the nfs config (I can't remember what it's called) and created three NFS shares (to /home/storage/video, /home/storage/pictures and /home/storage/music); these three folders are now visible on my Popcornhour when browsing the NFS network.

I have been quite pleased with NFS so far. My wife and I watched a film (.avi, but divx internally I believe) streamed from the bubba over a 11g Wifi network (54MBps) and it worked flawlessly. I had already copied the film to the PCH's hard-drive, in case the network couldn't cope, but I was very pleasantly surprised to have no buffering issues at all...

Posted: 27 Jan 2009, 13:43
by RealElwood
Is it normal to get this when restarting nfs-kernel-server:

Code: Select all

bubba:~# /etc/init.d/nfs-kernel-server restart
Stopping NFS kernel daemon: mountd nfsd.
Unexporting directories for NFS kernel daemon...done.
Not starting NFS kernel daemon: No exports.
Here's my exports

Code: Select all

# /etc/exports: the access control list for filesystems which may be exported
#               to NFS clients.  See exports(5).


Posted: 27 Jan 2009, 14:02
by ian
I have the following 4 shares in my /etc/exports file:


Does the folder dreambox exist in your video folder? If it doesn't, this would explain the "no exports" error message.

I tried to share a /home/[user]/downloads folder via NFS, and this didn't work; I assume that it's something to do with permissions, but as I did manage to share /home/[user] without any problems, it's not too serious...