Page 1 of 1

Erase files?

Posted: 08 May 2012, 16:36
by richardgullstrand
Hello kind linux-expert-soul, please help me erase files without r and w-rights through the web-interface...? (I installed Transmission and missed to change read and write-rights).

Understand that I must erase through the root and I´ve tried this in the command line:
- logged in as user
- switched to root by su
- found the file through find + directory ("Downloads" in this case, home/user/downloads)
Then, when I try to run rm + file´s name, it says "No such file or directory". How do I get into the right directory to be able to erase within it?

Problem nr 2: the files I want to delete are located inside the directory "Storage"... How do I enter this directory, it´s not available through user-login...

So, can anyone help erase files (or a hole directory) in "Storage"?

By the way, which setup is the most convenient for getting full r and w-rights? Now I run "umask: 0", but understand that a command like chmod could be better? Is it possible to fix by using a certain setting in the user mode (within the web-interface)?

Thank you, friend out there

Re: Erase files?

Posted: 09 May 2012, 15:07
by nobody
you ask for a web solution, but you seem to be using shell commands yourself. Shell is easiest indeed, so I'm giving you the shell answer. Apologies if this is not what you want but I do not know the GUI answer

Code: Select all

find /some/specific/location -name *mp3 -perm /u+w,g+w  -exec rm {} \;
PROTIP: try it without the exec part first to make sure you do not delete files you want to keep