B2+Lenny+SqueezeCenter

How are you using your Bubba Two or Excito B3? Got pictures? Share here!
Post Reply
smartin
Posts: 3
Joined: 23 Sep 2009, 15:50

B2+Lenny+SqueezeCenter

Post by smartin » 23 Sep 2009, 16:16

Hi all,

*** NOT FOR THE WEAK OF HEART ***

A while ago I decided to upgrade my Bubba2 to Lenny, as all the servers I have are on this version. I edited my /etc/apt/sources.list to point directly to my local debian mirror, removed the entries to the excito repositories, did and apt-get update/dist-upgrade and ended up with a working Lenny installation!

Of course you will have notices that I lost all the Bubba2 installed software. I wasn't too worried losing the Bubba HTML administration interface as I don't really use it. What I did lose was squeezecenter and this was a BIG blow. I tried adding "deb http://debian.slimdevices.com stable main" to my /etc/apt/sources.list but Logitech does not support PPC!

After messing around for quite a while I eventually managed to work out what was going on. If anybody wants to do this then here is what I think is a minimum set of steps. Perform all of these as root. (Be careful if you start SqueezeCenter by hand as root as it creates some files and will leave them with root privileges which means when you try to use the init scripts it won't work... You have been warned).

1.- Download squeezecenter_7.3.3_all.deb from the Logitech Squeezebox site

2.- Install SqueezeCenter using "dpkg -i squeezecenter_7.3.3_all.deb". You will probably have some dependency problems here, I resolved them using "dselect".

3.- The installation tries to start SqueezeCenter but this will fail, so stop it using /etc/init.d/squeezecenter stop.

4.- Run "/usr/share/squeezecenter/Bin/build-perl-modules.pl DBD::mysql DBI XML::Parser::Expat HTML::Parser JSON::XS Compress::Zlib YAML::Syck GD Encode::Detect Template". When it asks for the SqueezeCenter directory enter /usr/share/squeezecenter.

5.- Make sure that the file /var/lib/squeezecenter/cache/my.cnf has permissions 644 otherwise the mysql initialisation will fail.

6.- Start SqeezeCenter with /etc/init.d/squeezecenter start et voilá!

It took me a while to sort out step 4. If you run /usr/sbin/squeezecenter-server by hand instead of using the init script then it will give you a list of missing packages which for some reason does not include Encode::Detect and Template. Encode::Detect just made the squeezecenter crash. Template only seems to affect the SqueezeCenter HTML interface and I had to start debugging the SqueezeCenter software itself to find this one.

I have now have a working Bubba2 with Debian Lenny and an all singing all, dancing SqueezeCenter installation.

Hope this helps someone.

Regards

Simon Martin.

shadowbox
Posts: 35
Joined: 07 Oct 2008, 20:17

Re: B2+Lenny+SqueezeCenter

Post by shadowbox » 23 Sep 2009, 18:31

Simon, that's great to hear.

I've been considering upgrading Bubba2 by just pointing /etc/apt/sources.list at deb http://mirrors.kernel.org/debian/ testing main non-free contrib and letting it ride. However, I've been a little hesitant due to suspecting the excito people tweaked the kernel in some way.

But if all I'm losing is the HTML interface, which I've never used, then maybe I should take a stable at it when I have a weekend to spend on this hobby (because it always ends up being a weekend worth of debugging)

smartin
Posts: 3
Joined: 23 Sep 2009, 15:50

Re: B2+Lenny+SqueezeCenter

Post by smartin » 24 Sep 2009, 13:50

Hi shadowbox,

Actually, the debian upgrade was particularly painless. It was probably a couple of hours to do this, including the download time. Then began the fight with SqueezeCenter!

Don't worry about the kernel, as this is not upgraded. Seems like the Bubba kernel is booted straight out of flash. Any idea on how to upgrade the kernel anybody?

Regards.

carl
Posts: 474
Joined: 07 May 2008, 04:41

Re: B2+Lenny+SqueezeCenter

Post by carl » 24 Sep 2009, 14:05

smartin wrote:Hi shadowbox,

Actually, the debian upgrade was particularly painless. It was probably a couple of hours to do this, including the download time. Then began the fight with SqueezeCenter!

Don't worry about the kernel, as this is not upgraded. Seems like the Bubba kernel is booted straight out of flash. Any idea on how to upgrade the kernel anybody?

Regards.
One the kernel for BubbaServer (i.e. BubbaOne) is booted from flash, for BubbaTwo, the kernel is found in the bubba-kernel package. Regarding squeezecenter, you can build your own package using the source package on update.excito.org.
/Carl Fürstenberg, Excito Software Developer
http://www.excito.com
support@excito.com

Post Reply